Sui Testnet: Network-wide stall at block height 321,596,099

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 08:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2026 - 08:00 UTC

Update

Our engineers are closely listening to updates from the Sui foundation.
Posted Apr 03, 2026 - 05:00 UTC

Investigating

Sui Testnet is experiencing a network-wide stall at block height 321,596,099. This is not isolated to Quicknode. We will provide the next update as soon as new information becomes available.

Explorer: https://testnet.suivision.xyz/
Posted Apr 02, 2026 - 22:25 UTC
This incident affected: Sui (Sui Testnet - JSON RPC API).