Base Sepolia - Increase in `instrinsic gas too high` Errors on eth_estimateGas calls

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 08:11 UTC

Monitoring

Our engineers completed upgrading the Base Sepolia node infrastructure to 0.7.6


https://github.com/base/base/releases/tag/v0.7.6
Posted Apr 21, 2026 - 05:00 UTC

Identified

Foundation cut a new release with a couple of bug fixes for Azul (latest hardfork) on Base Sepolia.


https://github.com/base/base/releases/tag/v0.7.6
Posted Apr 21, 2026 - 00:30 UTC

Investigating

We are investigating an increase in `instrinsic gas too high` API errors on `eth_estimateGas` requests on Base Sepolia that started with the Sepolia Azul Upgrade at 18 UTC today.

We are working with the Base team to address this issue and will update this status with findings and resolution ASAP.
Posted Apr 20, 2026 - 19:43 UTC
This incident affected: Base (Sepolia - JSON-RPC API, Sepolia - WebSocket API).