Mantle Mainnet Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved and Mantle Mainnet nodes in the IAD region are fully operational. Thank you for your patience.
Posted Jul 26, 2026 - 14:48 UTC

Monitoring

The issue affecting Mantle Mainnet nodes in the IAD region has been resolved and services have returned to normal. We are continuing to monitor to ensure full stability.
Posted Jul 26, 2026 - 11:22 UTC

Investigating

We are investigating an issue causing 503 errors and degraded performance for Mantle Mainnet in the IAD region. Some requests may fail or experience elevated latency during this time. We will share updates as we have more information.
Posted Jul 26, 2026 - 10:23 UTC
This incident affected: Mantle (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).