Monad Testnet: block stalled at 8654706

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 14:02 UTC

Investigating

The Monad Testnet is currently experiencing a network-wide stall, with block production halted at block height 8654706. We are working with Monad Foundation team actively in the investigation.

Users may experience delays in transaction processing and network interactions until the underlying problem is identified and fixed. The team will likely provide updates as the situation progresses.
Posted Mar 20, 2025 - 11:47 UTC
This incident affected: Monad (Monad Testnet).