Stuck Network - 0G Galileo

Incident Report for Quicknode

Resolved

The 0G Galileo testnet network stall has been resolved, and the chain is progressing normally again. The issue was network wide and not isolated to QuickNode. We will continue monitoring for stability.
Posted Apr 01, 2026 - 20:47 UTC

Investigating

The 0G Galileo testnet network appears to have stalled at block 25181554 - The stall is network wide and is not isolated to Quicknode. Our team has reached out to the foundation for further information. This page will be updated as we receive further information.
Posted Apr 01, 2026 - 16:16 UTC
This incident affected: 0g (Beta) (Galileo — JSON-RPC API, Galileo — WebSocket API, Galileo — Streams, Galileo — Webhooks).