Worldchain Mainnet: degraded performance on archive nodes

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Sep 28, 2025 - 21:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2025 - 18:14 UTC

Identified

We’ve identified that the degraded performance is due to a combination of node client behavior and hardware limitations. Our team is actively working on a solution to mitigate the issue.

We expect to provide next update by September 28th 17:00 UTC
Posted Sep 27, 2025 - 13:38 UTC

Investigating

We are currently investigating degraded performance on our Worldchain mainnet archive nodes. This only impacts users accessing archival block data. If you are interacting with tip blocks, operations are normal.
Posted Sep 27, 2025 - 10:12 UTC
This incident affected: World Chain (Mainnet — JSON-RPC API, Mainnet — Websockets API).