Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 02, 2026 - 22:00 UTC
Update
Updating activity to Testnet only, at this time. Mainnet upgrade will be rolled out during a future maintenance window.
Posted Sep 02, 2026 - 21:28 UTC
Scheduled
We are upgrading our Monad Testnet infrastructure to v0.16.2
Highlights - Raptorcast v1 publish — nodes now publish proposals in the v1 raptorcast wire format on both the primary and secondary paths. - JSON-RPC error codes corrected across eth_call, eth_estimateGas, eth_simulateV1, debug_* and txpool_*.
Notable RPC/SDK changes [RPC] Fix JSON-RPC error codes and messages returned by the call, simulate, debug, txpool and websocket handlers. Ref: monad-bft PR #3228 [RPC] Fix zero-fee eth_calls — a zero maxFeePerGas is no longer raised to the base fee, matching geth and reth. Ref: monad-bft PR #3164 [RPC] Fix EIP-1898 compatibility for BlockTagOrHash. Ref: monad-bft PR #3163 [RPC] eth_createAccessList now accepts state overrides. Ref: monad-bft PR #3179
Notable robustness changes [Consensus] A validator publishes only the first accepted proposal to its full nodes, so an equivocated proposal is no longer forwarded. Ref: monad-bft PR #3180 [RPC] Concurrency limiter for eth_feeHistory, bounding memory on large block ranges. Ref: monad-bft PR #3212 [EVM] Runloop fix for when the node resets to the start block number. Ref: monad (execution) PR #2501