Aleo Mainnet - Block Height Lagging Behind Tip

Incident Report for Quicknode

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2026 - 17:29 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 11, 2026 - 21:00 UTC

Investigating

The QuickNode team is investigating degraded performance of Aleo Mainnet — nodes are currently reporting block heights behind the network tip. Users may experience stale block height responses. We will update this page as we acquire new information.
Posted Jun 11, 2026 - 16:40 UTC