Dashboard RPC Logs Unavailable - Non-USA Regions Impacted

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 17:44 UTC

Investigating

Our team is investigating an issue that is impacting the delivery of in-dashboard RPC Logs. Impact primarily to traffic served from Non-USA hosted nodes. http://dashboard.quicknode.com/endpoints/{id}/logs
Posted Jun 04, 2025 - 17:12 UTC
This incident affected: QuickNode Products (RPC Logs).