The upstream feed connection issues have stabilized and we are monitoring for stability.
Posted Sep 04, 2026 - 17:15 UTC
Identified
Users may continue to experience degraded performance and issues with transaction landing on Robinhood Mainnet. We are currently investigating connection issues regarding the sequencer feed and are closely listening to updates from the foundation.
Posted Sep 04, 2026 - 16:20 UTC
Update
The RobinHood foundation team has confirmed everything has returned back to normality. Our engineering team is actively monitoring performance.
Posted Sep 04, 2026 - 13:53 UTC
Update
The RobinHood foundation team has been notified and is actively investigating, this appears to be unrelated to Quicknode. We will provide further updates as more information becomes available.
Posted Sep 04, 2026 - 13:23 UTC
Investigating
We are investigating increased latency on RobinHood Mainnet. The Quicknode team has notified the foundation and will update this page as we acquire new information.