Aptos Testnet stalled at block 448903264

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 20:29 UTC

Identified

Aptos team verified testnet is offline. Expect updates as new information becomes available from foundation team.
Posted Apr 03, 2025 - 17:52 UTC

Investigating

We are currently investigating this issue.
Posted Apr 03, 2025 - 17:47 UTC
This incident affected: Aptos (Testnet - REST API).