[Standard] Morph - Mainnet & Hoodi - Upgrade to morph-v2.2.5 & node-v0.6.1

Scheduled for Aug 17, 01:00 - 05:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 11, 2026 - 14:37 UTC

Scheduled

We are upgrading our Morph Mainnet and Hoodi infrastructure to morph-v2.2.5. This release addresses JWT validation enforcement on authenticated WebSocket endpoints, corrects intrinsic gas estimation for transactions with access lists, and includes performance optimizations to DeriveSha.

During the maintenance window, brief interruptions to RPC availability may occur.

RPC Changes:
Authenticated WebSocket endpoint — JWT validation is now strictly enforced; requests without a valid JWT will be rejected.
eth_estimateGas — Gas estimation for transactions with access lists has been corrected to properly calculate intrinsic gas costs.

https://github.com/morph-l2/go-ethereum/releases/tag/morph-v2.2.5
Posted Aug 10, 2026 - 19:57 UTC
This scheduled maintenance affects: Morph (Mainnet — JSON-RPC API, Hoodi — JSON-RPC API).