Stacks Mainnet Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved. Stacks Mainnet is operating normally.
Posted Aug 24, 2026 - 13:24 UTC

Monitoring

A fix has been implemented and services have returned to normal. We are monitoring closely to ensure stability.
Posted Aug 24, 2026 - 12:53 UTC

Investigating

We are currently investigating degraded performance on Stacks Mainnet, with elevated latency and 503 errors. We will provide updates as more information becomes available.
Posted Aug 24, 2026 - 12:07 UTC
This incident affected: Stacks (Mainnet — REST API, Mainnet — Websockets API).