BSC Testnet archive node is stuck at block number 40231834
Incident Report for QuickNode
Resolved
This incident has been resolved.
Posted May 11, 2024 - 09:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2024 - 08:06 UTC
Investigating
We observe BSC testnet archive node is stuck at block number 40231834. You may experience problems when retrieve block states for any the block height is after this number. Our team is investigating on the issue.

All our BSC testnet full nodes are operating as normal.
Posted May 11, 2024 - 07:50 UTC