Blast Sepolia : Network-wide Stall

Incident Report for Quicknode

Identified

Our engineers are closely monitoring updates from the foundation. Please find the next update by 06:00 UTC.
Posted Feb 13, 2026 - 06:19 UTC

Investigating

We are currently experiencing a network-wide stall on Blast Sepolia network at block 33,103,445 Customers will be unable to query new blocks or submit transactions until the network resumes block production. This is an upstream issue affecting the entire Blast Sepolia network.
Posted Feb 12, 2026 - 23:58 UTC
This incident affects: Blast (Sepolia — JSON-RPC API, Sepolia — WebSocket API, Sepolia — Webhooks, Sepolia — Streams).