Peaq Mainnet - Block Height Stall 9,544,221

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 22:04 UTC

Investigating

We are currently investigating a block production stall on Peaq Mainnet. The same issue is reflected on the public block explorer, confirming this is a network-level incident. The Peaq Foundation has acknowledged the issue and is actively working on a resolution. We will provide further updates as they become available.
Posted Mar 23, 2026 - 13:10 UTC
This incident affected: Peaq (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).