Polygon Amoy Testnet , Elevated Network Load (Scheduled Stress Test)

Incident Report for Quicknode

Update

Our team is actively in discussion with the foundation to address the prolonged 503s on Polygon Amoy Testnet. You may continue to experience 503 errors and timeouts. We will provide updates as more information becomes available.
Posted Aug 06, 2026 - 18:09 UTC

Update

We're currently investigating prolonged 503s on Polygon Amoy Testnet following the conclusion of Polygon's scheduled stress test. You may continue to experience 503 errors and timeouts. We will provide updates as more information becomes available.
Posted Aug 06, 2026 - 14:33 UTC

Investigating

Polygon Labs is running load/stress testing on Amoy Testnet starting at 12:00 PM UTC today. You may experience higher-than-usual latency or elevated network load during this window. No action is needed on your end, we're monitoring and will update this page if anything requires attention.
Posted Aug 06, 2026 - 12:42 UTC
This incident affects: Polygon (Amoy — JSON-RPC API, Amoy — Websockets API, Amoy — Webhooks, Amoy — Streams).