Solana-Testnet: Degraded Performance

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 22:29 UTC

Monitoring

All Solana-Testnet nodes have recovered. We are monitoring performance to ensure stability and will provide an update upon confirmation or if further action is required within 10 minutes.
Posted Sep 03, 2025 - 22:18 UTC

Identified

Our team is continuing to work on restoring service on our US-E Solana-Testnet nodes.
No customer action is needed at this time. We will share another update regarding 503 mitigation efforts by 22:20 UTC.
Posted Sep 03, 2025 - 21:16 UTC

Investigating

We have identified a recent error spike on one of our Solana Testnet node clusters.
Some customers may be seeing elevated 503 responses from requests on the network. Our team is working to restore services fully and will share another update within 20 minutes.
Posted Sep 03, 2025 - 20:56 UTC
This incident affected: Solana (Testnet — JSON-RPC API, Testnet — Websockets API).