Abstract Mainnet: Block Height Stalled at 42,049,044

Incident Report for Quicknode

Resolved

Blockchain has caught up to tip and is functioning correctly. Our team will continue to monitor and optimize.
Posted Feb 24, 2026 - 13:16 UTC

Identified

Our team has applied the change recommended by the Abstract Foundation to restore nodes' syncing and is continuing to monitor catch-up progress.

The next update will be 14:00 UTC or sooner.
Posted Feb 24, 2026 - 08:32 UTC

Investigating

The Abstract Mainnet appears to have stalled at block 42,049,044. The QuickNode team is working with the foundation team on it and will update with more information once it is available.
Posted Feb 24, 2026 - 05:43 UTC
This incident affected: Abstract (Beta) (Mainnet — JSON-RPC API, Mainnet — WebSocket API, Mainnet — Webhooks).