Cosmos Mainnet Degraded performance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 17:31 UTC

Monitoring

We have implemented a fix, and service is recovering.

We are actively monitoring the situation and will share additional updates as we confirm continued stability
Posted Apr 01, 2026 - 17:08 UTC

Investigating

On Cosmos, customers may experience degraded performance for both HTTP and WebSocket traffic, including increased error rates (ex, 503 responses), elevated latency, and intermittent request failures.

To resolve this, we are performing an upgrade and working to restore normal service as quickly as possible. We will share the next update as soon as we confirm the cause and mitigation steps, and we’ll continue to provide updates as more information becomes available.
Posted Apr 01, 2026 - 15:09 UTC
This incident affected: Cosmos (Cosmos Mainnet — REST API).