Flow Testnet Performance Degradation

Incident Report for QuickNode

Resolved

This incident has been resolved. https://status.flow.com/incidents/9w2zlckh34ln
Posted May 23, 2025 - 19:27 UTC

Investigating

We are currently observing degraded performance on the Flow testnet execution. Users may experience 503. Our team is actively investigating the issue to identify the root cause and mitigate impact. We will provide further updates as soon as more information becomes available.

Thank you for your patience and understanding.
Posted May 23, 2025 - 13:24 UTC
This incident affected: Flow (Testnet — REST API).