Degraded Performance - Polygon Amoy Debug and Archive Requests

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 20:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 18:20 UTC

Identified

The Quicknode team has identified the cause of the degraded performance of Polygon Amoy archive and debug requests and our engineers are applying a fix. Users may still experience 503s during this time for archive and debug RPC calls.
Posted Apr 10, 2026 - 16:34 UTC

Investigating

The QuickNode team is investigating the degraded performance of Polygon Amoy archive and debug requests - we will update this page as we acquire new information. Users may experience 503s during this time for archive and debug RPC calls.
Posted Apr 10, 2026 - 15:52 UTC
This incident affected: Polygon (Amoy — JSON-RPC API, Amoy — Websockets API, Amoy — Webhooks, Amoy — Streams).