BSC Mainnet - Degraded Performance

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 19:06 UTC

Monitoring

We have implemented fixes for the degraded performance on BSC Mainnet endpoints and are currently monitoring the results.

Performance metrics are improving and we expect full resolution shortly. We will continue monitoring before marking this incident as resolved.
Posted Oct 07, 2025 - 15:01 UTC

Investigating

We have identified degraded performance on BSC Mainnet endpoints related to our backend infrastructure. We are investigating to determine the root cause and will provide an update soon.
Posted Oct 07, 2025 - 11:22 UTC
This incident affected: BNB Smart Chain (BSC) (Mainnet — JSON-RPC API, Mainnet — WebSocket API, Mainnet — Webhooks, Mainnet — Streams).