Flow EVM Mainnet Network Halted

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 05:34 UTC

Update

We are continuing to investigate this issue.
Posted Feb 24, 2026 - 01:19 UTC

Investigating

The Flow EVM Mainnet appears to have stalled at block 57,211,887 and Flow Mainnet at 143,217,050 - The QuickNode team is investigating and will update with more information once it is available.
Posted Feb 24, 2026 - 01:17 UTC
This incident affected: Flow (Mainnet — REST API, gRPC, Mainnet — Webhooks, Mainnet — Streams).