Solana Degradation in US Region

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 00:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2026 - 22:08 UTC

Investigating

We are currently investigating performance degradation affecting Solana endpoints in the US region. Customers may experience increased latency and slower RPC responses. Our engineering team is actively working to identify the root cause and restore normal performance.

Next update: : as we continue our investigation and have more information to share.
Posted Feb 24, 2026 - 21:06 UTC
This incident affected: Solana (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).