503s in Singapore Region, impacting Matic, XRP & Solana

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted May 17, 2025 - 17:10 UTC

Monitoring

A traffic reroute to alternate regions mitigated the 503 on impacted networks, team continues to monitor.
Posted May 17, 2025 - 15:38 UTC

Identified

Matic, XRP an Solana returning 503s in Singapore region due to upstream provider issue: https://www.teraswitchstatus.com/incidents/674qzd2m7vtq

Team working to move traffic to other regions
Posted May 17, 2025 - 14:53 UTC
This incident affected: Polygon (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — QuickAlerts, Mainnet — Streams), Solana (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams), and XRP Ledger (Mainnet — JSON-RPC API, Mainnet — Websockets API).