Solana Testnet — Block Height Stalled

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 07:56 UTC

Identified

This is a chain wide stalled. We are following up with the Foundation channel and working toward restoring normal block progression. Further updates will be provided as the situation develops.
Posted Jul 22, 2026 - 03:24 UTC

Investigating

Solana Testnet appears to have stalled at block 423,534,724 - The Quicknode team is investigating and will update with more information once it is available.
Posted Jul 22, 2026 - 02:42 UTC
This incident affected: Solana (Testnet — JSON-RPC API, Testnet — Websockets API, Testnet — Streams, Testnet — Webhooks).