Zkevm Mainnet: Block Height Stalled

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted May 16, 2025 - 13:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 16, 2025 - 12:53 UTC

Identified

Our engineering team is actively working on the fix.
Posted May 16, 2025 - 11:22 UTC

Investigating

We observed our zkEVM Mainnet block height progression is stalled, which may lead to degraded performance for users interacting with the network. This can impact data freshness, transaction confirmations, and access to the latest state, potentially causing delays or inconsistencies in services that rely on real-time blockchain data.

The team is investigating the issue.
Posted May 16, 2025 - 10:13 UTC
This incident affected: Polygon zkEVM (Mainnet — JSON-RPC API, Mainnet — Websockets API).