XRPLEVM Testnet Chain Halt

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 00:20 UTC

Investigating

The XRPLEVM Testnet is currently experiencing a chain halt following a network upgrade applied by the XRPLEVM Foundation earlier today. This is a network-level issue and the Foundation is actively working on a resolution. We are monitoring closely and will update this page as soon as more information is available.
Posted Feb 23, 2026 - 17:17 UTC
This incident affected: XRP Ledger (Testnet — JSON-RPC API, Testnet — Websockets API, Testnet — Streams, Testnet — Webhooks).