Intermittent Bitcoin Blockbook Stale Data Served

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jul 04, 2026 - 01:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2026 - 21:19 UTC

Investigating

We are investigating stale block data being served from the Blockbook service, specifically for `bb_getblock`. Our team will update this page as more information becomes available to us.
Posted Jul 03, 2026 - 16:33 UTC
This incident affected: Bitcoin (Mainnet — Blockbook RPC Add-On).