Berachain Mainnet Network Stalled at Block 23,259,488

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 05:34 UTC

Monitoring

Our engineers have successfully unwound the affected nodes past the stalled block and syncing has resumed. We are monitoring Berachain Mainnet for continued stability and will provide further updates as needed.
Posted Jul 08, 2026 - 20:32 UTC

Investigating

Berachain Mainnet appears to have stalled at block 23,259,488. The QuickNode team is investigating and will update with more information once it is available.
Posted Jul 08, 2026 - 19:03 UTC
This incident affected: Berachain (Mainnet — JSON-RPC API, Mainnet — WebSocket API, Mainnet — Streams, Mainnet — Webhooks).