Stellar Mainnet Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted May 14, 2026 - 18:38 UTC

Update

A fix has been applied and we are monitoring for stability. We will continue to update this page as needed.
Posted May 14, 2026 - 16:42 UTC

Monitoring

A fix has been applied and we are monitoring for stability. We will continue to update this page as needed.
Posted May 14, 2026 - 16:09 UTC

Investigating

The QuickNode team is investigating the degraded performance of Stellar Mainnet - Users may experience 503 errors during this time. We will update this page as we acquire new information.
Posted May 14, 2026 - 15:33 UTC
This incident affected: Stellar (Mainnet - REST API, Mainnet — JSON-RPC API).