Sahara Testnet degraded performance

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 09:47 UTC

Monitoring

We have applied a fix, expect to see node to recover in the next 20 minutes.
Posted Sep 12, 2025 - 09:38 UTC

Investigating

We are currently investigating this issue - we expect to provide an update within 30 minutes.
Posted Sep 12, 2025 - 09:27 UTC
This incident affected: Sahara (Testnet — JSON-RPC API, Testnet — Websocket API).