XRP Ledger EVM - Block Sync Issue

Incident Report for Quicknode

Resolved

After performing an upgrade, our XRP Ledger EVM infrastructure has successfully synced past block 4,688,680. Service is now operational and customers should be able to query the latest blocks and submit transactions normally. We will continue to monitor for stability.
Posted Feb 26, 2026 - 14:26 UTC

Investigating

We are currently experiencing an issue with our XRP Ledger EVM infrastructure stuck at block 4,688,680. Customers may be unable to query the latest blocks or experience delays in transaction confirmations. Our engineering team is actively working to resolve the sync issue and will provide the next update by 3PM UTC or sooner.
Posted Feb 26, 2026 - 13:51 UTC
This incident affected: XRP Ledger (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).