Blast Sepolia - Stuck Network

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 00:12 UTC

Monitoring

Blocks are syncing on the Blast Sepolia Network. We are monitoring performance to ensure stability and will provide an update upon confirmation or if further action is required within 10 minutes.
Posted Jan 13, 2026 - 23:58 UTC

Investigating

The Blast Sepolia Network is experiencing intermittent block stalls - The Quicknode team is investigating and will update with more information once it is available.
Posted Jan 13, 2026 - 16:18 UTC
This incident affected: Blast (Sepolia — JSON-RPC API, Sepolia — WebSocket API, Sepolia — Webhooks, Sepolia — Streams).