Osmosis Mainnet : Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted May 02, 2026 - 08:24 UTC

Monitoring

The Quicknode team is actively working with the foundation team on this. Nodes have recovered, but you may experience intermittent degraded performance for gRPC calls. We are monitoring performance to ensure stability.
Posted Apr 30, 2026 - 07:06 UTC

Identified

The issue has been identified, and a fix is being implemented. During this time, you may experience intermittent failures or degraded performance for gRPC calls.
Posted Apr 28, 2026 - 02:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2026 - 01:07 UTC

Identified

The Quicknode team is aware of the degraded performance on Osmosis Mainnet. This issue has been identified and our team is actively working on resolving the issue. Users may experience sporadic 503 errors during this time. We will update this page as we acquire new information.
Posted Apr 23, 2026 - 16:48 UTC
This incident affected: Osmosis (Select Access) (Mainnet — JSON-RPC API, Mainnet — Websockets API).