Aptos Testnet: Degraded Performance

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted May 14, 2025 - 03:07 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 14, 2025 - 02:44 UTC

Investigating

We are currently investigating this issue.
Posted May 14, 2025 - 01:40 UTC
This incident affected: Aptos (Testnet - REST API).