Stuck Network - Blast Sepolia

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 17:16 UTC

Investigating

The Blast Sepolia network appears to have stalled at block 36373475 - The Quicknode team is investigating and will update with more information once it is available.
Posted Apr 29, 2026 - 16:52 UTC
This incident affected: Blast (Sepolia — JSON-RPC API, Sepolia — WebSocket API, Sepolia — Webhooks, Sepolia — Streams).