Arb-Nitro debug_trace_blockByNumber error
Incident Report for QuickNode
Resolved
This incident has been resolved.
Posted Jan 06, 2025 - 15:13 UTC
Investigating
We have discovered a arb-nitro client bug that leads some debug_trace_blockByNumber requests to fail with an error:
"tracing failed: insufficient funds for gas * price + value: address"

Problem blocks: 291297454 and 291305011 - though others may exist.

We have raised this with the Arbitrum foundation and will implement a fix as soon as it's made available.
Posted Jan 02, 2025 - 20:41 UTC
This incident affected: Arbitrum (Mainnet Nitro — JSON-RPC API, Mainnet Nitro — Websockets API, Mainnet Classic — JSON-RPC API, Mainnet Classic — Websockets API, Mainnet — QuickAlerts, Mainnet — Streams, Sepolia - JSON RPC, Sepolia - Websockets API, Sepolia — QuickAlerts, Sepolia — Streams).