Celo Mainnet 503 Errors

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 16:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2026 - 15:41 UTC

Identified

We’re currently investigating intermittent `503` errors impacting Celo Mainnet requests.

Our team has identified the issue and is working to restore normal service as quickly as possible. We’ll continue monitoring and provide updates as soon as more information is available.

Thank you for your patience.
Posted Jul 27, 2026 - 15:02 UTC
This incident affected: Celo (Mainnet — JSON-RPC API, Mainnet — WebSocket API, Mainnet — Webhooks, Mainnet — Streams).