Stuck Network - Hedera Testnet

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 22:19 UTC

Monitoring

The Hedera Testnet network has resumed. Our team is monitoring for stability.
Posted Mar 06, 2026 - 21:51 UTC

Update

We are continuing to investigate this issue.
Posted Mar 06, 2026 - 21:51 UTC

Investigating

The Hedera Testnet network appears to have stalled at block 32392072 - The Quicknode team is investigating and will update with more information once it is available.
Posted Mar 06, 2026 - 21:42 UTC
This incident affected: Hedera (Testnet - JSON-RPC API, Testnet - REST API, Testnet — Streams, Testnet — Webhooks).