0g Galileo stalled at block height: 3,441,155

Incident Report for QuickNode

Resolved

The incident has been fully resolved, and all systems are operational. The network is stable, and block production has resumed as expected. We’ll keep light monitoring in place, but no additional impact is anticipated.
Posted Oct 24, 2025 - 18:43 UTC

Monitoring

Nodes have been upgraded, and blocks are moving again. We’ll continue monitoring to ensure stability, but no further impact is expected.
Posted Oct 24, 2025 - 16:04 UTC

Update

We expect to provide an update by 16:00 UTC today.
Posted Oct 24, 2025 - 14:21 UTC

Investigating

0G Galileo is stalled at block height 3,441,155. Our team is performing a node upgrade, and new block production is temporarily impacted.
Posted Oct 24, 2025 - 14:20 UTC
This incident affected: 0g (Beta) (Galileo — JSON-RPC API, Galileo — WebSocket API, Galileo — Streams, Galileo — Webhooks).