Degraded Performance - Ethereum Mainnet Archived Request

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 08:41 UTC

Identified

The underlying issue has been identified, and a mitigation is in place.
Some nodes have recovered, and 503s have been mitigated.
Quicknode teams are continuing to work to recover full capacity and monitor performance to ensure stability.
Posted Jun 25, 2026 - 08:14 UTC

Investigating

The Quicknode team is investigating the degraded performance of Ethereum mainnet archived nodes.

Customers may experience increased error rates, including 503 responses, when querying archive data.

We will update this page as we acquire new information.
Posted Jun 25, 2026 - 07:49 UTC
This incident affected: Ethereum (Mainnet — JSON-RPC API, Mainnet — Websockets API).