Stuck Network - B3 Mainnet is Stuck at Block 21846394

Incident Report for QuickNode

Resolved

Resolved explorer now moving https://explorer.b3.fun/blocks
Posted Apr 09, 2025 - 19:13 UTC

Identified

The B3 Mainnet appears to have stalled at block 21846394 https://explorer.b3.fun/blocks - The QuickNode team is investigating and will update with more information once it is available.
Posted Apr 09, 2025 - 18:21 UTC
This incident affected: B3 (Mainnet — JSON-RPC API, Mainnet — Websockets API).