Fuel Sepolia - Stuck Network

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 21:42 UTC

Investigating

Fuel Sepolia network appears to have stalled at block 59,642,794. The QuickNode team is investigating and will update with more information once it is available.
Posted Apr 09, 2026 - 21:33 UTC
This incident affected: Fuel (Beta) (Sepolia — GraphQL API).