Optimism Mainnet: Degraded Performance

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 19:40 UTC

Monitoring

We see our Optimism Mainnet is stabilised now, the network is operational. We will continue to monitor situation.
Posted Oct 07, 2025 - 08:14 UTC

Update

Following collaboration with the foundation, our engineers have determined the root cause and are taking further steps to restore the node infrastructure.

As we progress toward a resolution, please expect the next update on or before 9:00 UTC.
Posted Oct 07, 2025 - 07:00 UTC

Identified

We are experiencing a recurrence of 503 errors on the network.
Our team is continuing to work toward a full resolution. We will share another update by 05:00 UTC
Posted Oct 06, 2025 - 22:39 UTC

Monitoring

Our team has implemented a solution and is currently monitoring the network.
Elevated 503s have been resolved.
We will share another update within 10 minutes to confirm stability or if further action is required.
Posted Oct 06, 2025 - 22:23 UTC

Investigating

We are actively investigating degraded performance on the Optimism mainnet.
Some customers may experience elevated 503 errors.
As we progress toward a resolution, expect the next update within 30 minutes.
Posted Oct 06, 2025 - 21:49 UTC
This incident affected: Optimism (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Webhooks, Mainnet — Streams).