Stuck Network - Arbitrum Sepolia stuck on block 149,800,430

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted May 05, 2025 - 23:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 05, 2025 - 20:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 05, 2025 - 17:45 UTC

Investigating

The Arbitrum Sepolia appears to have stalled at block 149,800,430 - The QuickNode team is investigating and will update with more information once it is available.
Posted May 05, 2025 - 15:13 UTC
This incident affected: Arbitrum (Sepolia - JSON RPC, Sepolia - Websockets API, Sepolia — QuickAlerts, Sepolia — Streams).