Flow Testnet Delayed Block Production

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 19:34 UTC

Identified

Flow Testnet block production is delayed - Follow updates from the Flow Chain team here: https://status.flow.com/incidents/kdngmc7jgf8r
Posted Sep 23, 2025 - 19:24 UTC
This incident affected: Flow (Testnet — REST API).