Polygon Mainnet Performance Degradation

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 10:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2025 - 09:54 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 01, 2025 - 09:43 UTC

Investigating

The Polygon mainnet, hosted on Erigon nodes, is currently experiencing a network-wide stall at block 73,440,256. Our team is actively collaborating with the Polygon Foundation to resolve this issue.

User Impact:
* 503 errors
* Request timeouts

We will provide updates as the situation develops.
Posted Jul 01, 2025 - 09:07 UTC
This incident affected: Polygon (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — QuickAlerts, Mainnet — Streams).