Ethereum RPC Erigon archive backend nodes are stalled at height 23,296,063

Incident Report for QuickNode

Resolved

The synchronization issue affecting Ethereum Archive RPC Erigon nodes has been resolved. All nodes have resumed normal operation and are processing blocks beyond height 23,296,063.
Archive data access is now fully restored and all services are operating normally.
We will continue monitoring for stability.
Posted Sep 05, 2025 - 14:38 UTC

Investigating

We are currently investigating an issue where all Ethereum Archive RPC nodes are stuck at block height 23,296,063. Our engineering team is working to restore synchronization and resolve this issue affecting archive data access. We will continue to provide updates as we work to resolve this issue.
Posted Sep 05, 2025 - 11:04 UTC
This incident affected: Ethereum (Mainnet — JSON-RPC API).